Jobs Podcast iTunes Podcast RSS Tumblr @TimOfLegend @DoubleFine Google+ YouTube Facebook RSS
 
To participate in the excellent Double Fine Action Forums community, log in or register now!
 
[Resolved] Psychonauts Linux (Steam) - Fails to Start
Posted: 12 February 2013 03:48 PM
  [ Ignore ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

After downloading then launching the Linux version of Psychonauts, a black window opens momentarily then closes.
I receive the following error(s) in the console:

———
PSYCHONAUTS UNIX FILENAME: corrected ‘workresource/sounds/commonfx.isb’ to ‘WorkResource/Sounds/commonfx.isb’
GameApp::StartUp InitSoundFiles() completed in 0.13 seconds
GameApp::StartUp Load some common textures completed in 0.00 seconds
WARN: ENGINE: Lua garbage collection starting
FreeUnusedBlocksInBuckets released 0 Kb
ERROR: Assert in /home/icculus/projects/psychonauts/Source/game/luatest/RTEngine/AnimManager.cpp, line 529
false

Encountered Error:
Psychonauts has encountered an error

/home/icculus/projects/psychonauts/Source/game/luatest/RTEngine/AnimManager.cpp, line 529
false

Please contact technical support at http://www.doublefine.com.

Trace/breakpoint trap (core dumped)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Game removed: AppID 3830 “Psychonauts”, ProcID 14992
———

With lines and lines of “PSYCHONAUTS UNIX FILENAME: corrected ...” before the above console output (seems to be for every asset file for whatever reason).

System Info:
Processor Information:
Vendor: AuthenticAMD
Speed: 3411 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu Raring Ringtail (development branch) (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-5-generic
X Server vendor: The X.Org Foundation
X Server release: 11302000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 465/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 313.09
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x6c4
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 17.05” x 10.67” (20.08” diag)
43.3cm x 27.1cm (51.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT1708S

Memory:
RAM: 7985 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 461263 Mb
Largest Free Hard Disk Block: 216005 Mb

Any ideas or suggestions on getting it working would be greatly appreciated.

Profile
 
Posted: 13 February 2013 10:22 AM
  [ Ignore ]   [ # 1 ]
Double Fine
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  746
Joined  2011-10-19
SIR_Taco - 12 February 2013 03:48 PM

After downloading then launching the Linux version of Psychonauts, a black window opens momentarily then closes.
I receive the following error(s) in the console:

———
PSYCHONAUTS UNIX FILENAME: corrected ‘workresource/sounds/commonfx.isb’ to ‘WorkResource/Sounds/commonfx.isb’
GameApp::StartUp InitSoundFiles() completed in 0.13 seconds
GameApp::StartUp Load some common textures completed in 0.00 seconds
WARN: ENGINE: Lua garbage collection starting
FreeUnusedBlocksInBuckets released 0 Kb
ERROR: Assert in /home/icculus/projects/psychonauts/Source/game/luatest/RTEngine/AnimManager.cpp, line 529
false

Encountered Error:
Psychonauts has encountered an error

/home/icculus/projects/psychonauts/Source/game/luatest/RTEngine/AnimManager.cpp, line 529
false

Please contact technical support at http://www.doublefine.com.

Trace/breakpoint trap (core dumped)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Game removed: AppID 3830 “Psychonauts”, ProcID 14992
———

With lines and lines of “PSYCHONAUTS UNIX FILENAME: corrected ...” before the above console output (seems to be for every asset file for whatever reason).

System Info:
Processor Information:
Vendor: AuthenticAMD
Speed: 3411 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu Raring Ringtail (development branch) (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-5-generic
X Server vendor: The X.Org Foundation
X Server release: 11302000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 465/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 313.09
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x6c4
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 17.05” x 10.67” (20.08” diag)
43.3cm x 27.1cm (51.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT1708S

Memory:
RAM: 7985 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 461263 Mb
Largest Free Hard Disk Block: 216005 Mb

Any ideas or suggestions on getting it working would be greatly appreciated.

Sounds like a corrupt file. Have you tried verifying the integrity of your cache through steam?

Profile
 
Posted: 13 February 2013 03:27 PM
  [ Ignore ]   [ # 2 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

Nathan,

Thanks for the reply.

Yes, I have done the integrity check a few times. No errors found.
I also tried copying the game files from my (working) Steam install on Windows, but end up with the same error. I have since reverted back to the original Linux download.

Any idea what condition is failing on line 529 of AnimManager? It could possibly be a dependency issue.

Profile
 
Posted: 13 February 2013 04:24 PM
  [ Ignore ]   [ # 3 ]
The Smell of Cinnamon Rolls
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  72
Joined  2012-03-23

I think I had a similar error a while ago and it was caused by messed up configuration files. I’m not promising any miracle, but I’d try removing this folder: ~/.local/share/Psychonauts and see if the game starts afterwards.

Profile
 
Posted: 13 February 2013 04:27 PM
  [ Ignore ]   [ # 4 ]
The Smell of Cinnamon Rolls
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  72
Joined  2012-03-23

Oh and if you’re running the game from steam, try disabling the overlay.

Profile
 
Posted: 13 February 2013 04:32 PM
  [ Ignore ]   [ # 5 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

ClapBedon,

Thanks for the suggestion.
Unfortunately my ~/.local/share/Psychonauts/ directory is empty because it has yet to successfully start. I removed it anyway, but end up with the same result.

Cheers

Profile
 
Posted: 13 February 2013 04:36 PM
  [ Ignore ]   [ # 6 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10
ClapBedon - 13 February 2013 04:27 PM

Oh and if you’re running the game from steam, try disabling the overlay.

Thanks again for the suggestion.
Didn’t solve the problem though wink

Profile
 
Posted: 13 February 2013 04:59 PM
  [ Ignore ]   [ # 7 ]
The Smell of Cinnamon Rolls
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  72
Joined  2012-03-23

And just for the sake of trying something, does the game work when you use one of the HumbleBundle builds? You can find them here:
http://treefort.icculus.org/psychonauts/

Profile
 
Posted: 13 February 2013 05:33 PM
  [ Ignore ]   [ # 8 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

ClapBedon,

Tried the 0.3, 0.4, 0.5, 0.6 and the test (which is older) with the same result unfortunately. Still stuck on AnimManager line 529 for whatever reason.

I appreciate the suggestions.

Profile
 
Posted: 13 February 2013 06:10 PM
  [ Ignore ]   [ # 9 ]
The Smell of Cinnamon Rolls
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  72
Joined  2012-03-23

Humpf, I’m starting to run out of ideas…

Have you tried fiddling with the DisplaySettings.ini config file where the binary is located? Try a lower resolution maybe, windowed mode.

And if you ‘ldd Psychonauts’, does it report any missing library?

Maybe there’s something wrong because you’re using Raring Ringtail? Did the game work with Quantal?

Profile
 
Posted: 13 February 2013 06:38 PM
  [ Ignore ]   [ # 10 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

ClapBedon,

I’ve tried the default DisplaySettings.ini (which is 800x600 I believe). I’ve tried changing it to what my (working) Windows settings are (1680x1050). I’ve also tried leaving it at 800x600 windowed and setting the rest of the settings to false. No avail I’m afraid.

Did ldd a while ago and tried it again now. Every library matches dependency.

I’ve considered the OS version, but if the libraries match I’m not sure what else could be causing the problem. Unfortunately I don’t have a Quantal install at the moment to test.

I’m not exactly new to Linux, been using it since 1999, but I’m no expert either.
ldd output:
      linux-gate.so.1 =>  (0xf77da000)
      libSDL-1.2.so.0 => /home/phil/Steam/SteamApps/common/Psychonauts/./libSDL-1.2.so.0 (0xf7744000)
      libopenal.so.1 => /home/phil/Steam/SteamApps/common/Psychonauts/./libopenal.so.1 (0xf76f6000)
      libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf75df000)
      libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf759c000)
      libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf757f000)
      libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf73cc000)
      libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf73b1000)
      libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf73ab000)
      librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf73a2000)
      /lib/ld-linux.so.2 (0xf77db000)

I’ve also tried replacing the supplied Psychonauts SDL and OpenAL libraries with the newer versions on my system, but no change.

Cheers

Profile
 
Posted: 13 February 2013 06:59 PM
  [ Ignore ]   [ # 11 ]
The Smell of Cinnamon Rolls
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  72
Joined  2012-03-23

Oh well, I figured the game wouldn’t have even started if some libraries were missing. Humpf, now I’m really stumped.

Maybe the best thing to do now is to ‘strace -o <out_file> ./Psychonauts’, send the output to .(JavaScript must be enabled to view this email address), and hope for a fix…

Sorry about that. Let us know if you ever find a workaround.

Profile
 
Posted: 13 February 2013 07:03 PM
  [ Ignore ]   [ # 12 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

Your help is greatly appreciated.

I’ll send them the output and report what comes of it in the event that someone else comes across the same problem.

Thanks again,
Cheers

Profile
 
Posted: 14 March 2013 06:35 PM
  [ Ignore ]   [ # 13 ]
Newbie
Avatar
Broken Age Backer MASSIVE CHALICE Backer
Total Posts:  8
Joined  2013-02-10

Just to update on the issue:

I recently removed/uninstalled Psychonauts from Steam (Linux) and re-downloaded the entire game again.
The game now starts normally and I haven’t run into any issues. Not sure why the game cache integrity check succeeded before.

I did not receive a response from the support e-mail I sent, but referenced this thread for them to see what has been attempted. Hopefully they will read this and see that it’s resolved.

Thanks to all those that helped, it’s greatly appreciated.

Cheers

Profile
 
 
To participate in the excellent Double Fine Action Forums community, log in or register now!